Skip to main content
Navigate Up
Sign In
SMC|Academic Programs|Health Sciences|Nursing|PLATO Online Orientation|Required Plug-ins for PLATO

Required Plug-ins for PLATO

Required Plug-ins

Since PLATO courseware runs in your Internet browser, there are a few browser plug-ins that are required. The first time you use PLATO on your computer, the PLATO website will run a check to see what plug-ins you need to download. Then, PLATO will automatically provide you a link to download these plug-ins.

Remember, PLATO will detect if you need any of the plug-ins and then direct you to download any missing plug-ins.

Here is a list of plug-ins required for both Windows and Mac computers: